This is not a valid archive - SOLUTION!!!

Miscellaneous updates and information for Smoothwall Express 3

Moderator: Forum Moderators

This is not a valid archive - SOLUTION!!!

Postby wkitty42 » Sat Apr 05, 2008 8:02 pm

Etherlord wrote:being still stuck on slODEM, I downloaded Update2 at work and tried to install it via the webGUI=>Maintenance=>Updates page by clicking the Advanced button.
It seemed to upload fine, but then I was presented with This is not a valid archive
(note, rather than "This is not an authorised update, or your patchlist is out of date.")

Long story short....
line 100 of /httpd/cgi-bin/updates.cgi wrote:unless (system("cd /var/patches/$$ && /etc/bin/tar xvfz patch.tar.gz > /dev/null") == 0)

The problem is that tar is not in /etc/bin :shock: meaning that SW doesn't know what the update file is because it doesn't have a program to do something with it (decompress/unpack). Hence the default 'file error' error message of "This is not a valid archive".

line 100 of /httpd/cgi-bin/updates.cgi should have wrote:unless (system("cd /var/patches/$$ && /usr/bin/tar xvfz patch.tar.gz > /dev/null") == 0)


Once you have refreshed the page (to load the edited code), SW should now be able to decompress/unpack the update and finally install it :)

I don't know if this is one of the things that gets fixed by Update2, but until I fixed it, I was unable to install Update2
(The EGG came first I tell you!!! :wink: )


Bitbeisser wrote:
axel_2078 wrote:Am I the only one that didn't have this problem? My update downloaded and installed without the error message mentioned in this post. I just rebooted and haven't noticed any problems so far *fingers crossed*.

The problem seems to effect "manual" (Advanced) updates only. The automatic update (just hitting the update button) will work just fine...

Ralf
User avatar
wkitty42
solar system
 
Posts: 3731
Joined: Fri Mar 26, 2004 5:06 pm
Location: Central North Carolina, USA

Return to SWE3 Misc

Who is online

Users browsing this forum: CommonCrawl [Bot] and 0 guests